What's New in Max 7

What's New in Max 7?


A New Interface

The user interface has been completely reworked, with a focus on making things simpler and more approachable. Toolsbars are provided for easy access to objects, media and other content collections, and use of items found on the toolbar is accomplished with a single drag gesture. Formatting of objects uses style information, allowing you to change an entire user-interface with a single style redefinition. All of these changes were accomplished while maintaining compatibility with existing patchers - opening them in Max 7 will map colors, sizes and fonts to their Max 7 equivalents.

The Patcher Frame

The patcher window is now surrounded by toolbars. The top toolbar provides an object palette, where you can click or drag objects to add them to your patcher. There is also a format palette for object and patcher design, and a search box that provides quick access to the built-in documentation.

The left toolbar provides access to browsers that allow access to media, objects, high-level modules and user-defined collections. These browsers, in combination with new Max features, allow you to drag items directly onto the patcher with immediate access to the content.

The right toolbar provides control of the sidebar, where you can view the Max window, the object inspector and lessons. There is also an audio meter and gain control, and a calendar that helps you keep track of recent work.

Finally, the bottom toolbar is similar to the Max 6 toolbar, but introduces new functions like the snippet save button and an audio on/off button (which replaces the Max 6 mini-mixer).

Formatting and Styles

Clicking on the paint bucket icon in the top toolbar will reveal the Format Palette. This is where you can change the colors, font and other stylistic settings for a selected object. If no object is selected, you are presented with the patcher-level formatting, which gives you the ability to change the appearance of all objects and patchcords within the patch.

Styles are appearance settings that can be stored for an object, multiple objects or even an entire patcher. You can define some or all of the settings of the selected items; hierarchical definition of styles will work like other similar systems (think CSS...), where undefined parameters will be inherited from lower level styles.

The Object Action Menu

The circular object menu has been replaced by the Object Action menu, which provides access to attributes, available messages, reference and help documentation and transforming actions for any object. Objects that have defined prototypes can be altered from this menu, and objects with referenced files can have the files selected here as well.

Draggable Workflow

A number of new tools are available that provide for rapid patch building based on dragging content from the left toolbar. Adding audio or video files from the browsers will create a playlist object that combines the media with a player - thus removing the large number of steps previously required for creating media players.

Additionally, two of our modular patching libraries - BEAP and Vizzie - are now directly available from the left toolbar. You can drag modules from these libraries into your patch for quick creation of modular performance patches. You will also find draggable access to VST/AU plugins and Max for Live devices, improving on the support for these important tools.

Patcher Snapshots

The new 'Snapshot' system allows you to capture the parameters of objects in your patcher, and either embed them in your patcher, or store them as a special kind of file (with a .maxsnap extention). The user interface for snapshot management of parameters is found in the by selecting Parameters from the View menu. You can also send 'snapshot' and 'restore' messages to thispatcher, vst~ and amxd~ objects to store context-specific snapshots.

Other Interface Changes

  • You can tranform bpatcher to/from subpatchers using the Transform menu option.
  • The triangles that appear within toolbars allow you to 'unpin' them, which will hide the toolbar until you mouse over the window border.
  • Toolbar configurations can be changed by control-clicking on any toolbar. Control-clicking on any item will remove it from the toolbar.

Live Devices in Max

Max can now open and save Max for Live devices (AMXD files) without having Ableton Live installed or running. The user interface for the devices can be viewed within the patcher or opened as a separate window. Live devices are easily dragged from the Plug-ins browser on the left toolbar, or can be entered by name into an amxd~ object.

Pitch and Time Engine

One of the most exciting new features of Max is the addition of a pitch-shifting and time compression engine. Rather than creating all new objects to expose these functions, you can access there features within objects like groove~, sfplay~ and buffer~. You can also make changes using new objects like retune~, pitchshift~ and stretch~.

New File and Documentation Browser

The File and Documentation Browsers have been redesigned for Max 7 to provide a higher level of discoverability and easier use. The File Browser can be opened through the File->Browse Files menu option, and adds better search functions, tracking of recently used files and access to Collections, a new way of organizing your files.

The documentation browser can be accessed through the Help menu or the Object Action menu, or by typing any search phrase into the Search Box on the top toolbar. A search will return all files that match the search phrase, including reference documents, help files, tutorials, guides and example patches.

OpenGL Enhancements

OpenGL in Jitter now has support for multiple render targets, multiple texture outputs, shadow rendering and support for high resolution retina displays on the Macintosh. But perhaps the most exciting addition to the Max-OpenGL connection is the the jit.world object, which is a single object that creates a window with an OpenGL rendering context, optional physics, various output options and interaction with video content. All that is required is a jit.world and a single toggle to start working in Max's OpenGL environment.

And more...!

  • A new web-based authorization system.
  • A new preference allows the selection of higher performance video engines. Mac OS 10.8 (or greater) users will default to the use of the AVF engine, which can provide much greater performance with hi-def video.
  • New preferences to modify editor appearance and functionality.
  • Improved support of compressed audio formats, including support of MP3 files as a primary audio file type.
  • Many new Live Devices for use within Max - or within Live!
  • Several new keyboard-activated patching enhancements.
  • Improvements to the both process scheduling and patcher drawing.
  • Significant improvements in Gen patcher load and compilation performance
  • Javascript coding enhancements through the use of require and include module references.
  • Max 7 will recover offer an option to recover your work after a crash.