Sharing Patches

Sharing Patches

Max patcher files are in a text-based format, so they are easy to share. You can copy all or part of a patcher to the clipboard, then paste it into an e-mail message. You can also receive e-mail messages with patchers, copy them to the clipboard, and paste them into Max.

Copying a patcher into an e-mail message

  • If you want to send e-mail with part of a patcher, select the objects you want to include. If you want to include all objects, choose Select All from the Edit menu.
  • Choose Copy from the Edit menu to copy the selected objects to the clipboard
  • Switch to your e-mail client. Paste the contents of the clipboard into a message

Copying a patcher into an e-mail message in compressed format

Max offers a compressed text format for copying patcher data to the clipboard. This may be useful when posting excerpts of a patcher on a public forum or mailing list. The text is "unreadable" but will be a small fraction the size of the usual text format.

  • Select the part of the patch you wish to copy
  • Choose Copy Compressed from the Edit menu to copy the selected objects to the clipboard
  • Switch to your e-mail client. Paste the contents of the clipboard into a message

Opening a patcher from an e-mail message

Max can create objects from text on the clipboard in the old Max 4 text format, standard Max format, or the compressed format.

  • Because there may be a lot of text involved in the patcher data, the easiest technique for selecting all of the data is select a line at the beginning of the text, then scroll to the end of the message and Shift-click to select the end of the text.
  • Once all of the text is selected, choose Copy from the Edit menu in your e-mail client. If you are manually selecting all the data, be sure to include the begin_max5_patcher and end_max5_patcher lines in their entirety.
  • Switch to Max.
  • If you want to create a new patcher window with the patcher data you've received, choose New From Clipboard from the File menu. A new patcher window will appear with the objects from the e-mail message.
  • If you want to paste the objects in the e-mail message into an existing unlocked patcher, choose Paste from the Edit menu.