Patches in Text Format

The most convenient way to exchange Max patches with others is to convert them to text files which can be emailed more easily than trying to send patches as email attachments or creating StuffIt files. Max lets you convert an entire patch or a portion of one to a text file, and to convert Max patches saved in text format to visual patches automatically.

You can exchange Max patches in text format between Macintosh and Windows machines. If a text format Max patch contains a third-party Max object or an abstraction you don't have on your system, you'll see an error message in the Max Console

and the Max object will be differently colored, although it will appear with the correct number of inlets and outlets.

If someone sends you a Max patch with a user interface they have created using Presentation Mode and they have set the patch to open in Presentation mode, you'll see the user interface when you convert the file. To edit the patch, switch to Patcher mode by clicking on the Presentation Mode icon in the Patcher Window toolbar.


Saving a finished patch as text

  • Choose Open As Text... from the File menu and use the file dialog box to select your file. A new text window will open that contains the file you have selected in text form. Choose Select All from the Edit menu to select the text, then choose Copy from the Edit menu to copy the text to the clipboard. You can paste this text into an email or a text file to share with others. Note that if your patcher contains any abstractions, you will need to open and save them separately.

Saving a Max patch in Text format

  • Choose Save As... from the Edit menu, and then chose Max text file from the Format pop-up menu in the file dialog. The file will be saved as a Max text file (.mxt).

Saving a portion of a patch as text

  • Select the patch or portion of a patch you wish to save as text. Choose Copy from the Edit menu to copy the selected portion to the clipboard. Open a text editor or email client and paste the contents of the clipboard into a new document.

Converting a text file to a Max patch

  • Select the textfile or portion of an email that contains the Max patch. Be sure that you copy the entire file, which begins and ends with a single curly bracket ( {/} ) as the very first character on a line. Copy the selected portion to the clipboard. Choose New From Clipboard from the File menu, and a new Patcher window will be instantiated, and the pasted-in text will appear as a Max patch.
    Note: Max uses the Unicode format. which means that email clients that don't support Unicode (such as Eudora) won't allow for simple copying and pasting from the clipboard. If you copy a Max patch and it doesn't paste into your email client as a text file, click here for some helpful advice.