Presentation Mode

Presentation Mode

Presentation mode allows you to arrange and resize user interface objects in your patch independently of their functional position and size in patching mode (where you connect objects together). Because you cannot "patch" in presentation mode, it is possible to provide an editing experience closer to a typical object-oriented drawing application.

  • You can toggle back and forth between patching and presentation modes as you’re working. In both modes, you can lock and unlock the patcher window to switch between editing and running the patch.
  • Max also supports multiple views of a patcher. You can use this feature to leave one view in patching mode while keeping a second view in presentation mode. Whenever you select an object in one view, it will be highlighted in the other view.
  • By enabling the Open in Presentation attribute in the patcher inspector, you can set a patch so that it opens in presentation mode.

Switching between Patching and Presentation Modes

  • Click on the Presentation Mode button on the toolbar at the bottom of the patcher window

When a patcher is in presentation mode, the Presentation Mode button in the Patcher toolbar will turn green and the word (presentation) will appear in the title bar of the Patcher window to indicate that you are in presentation mode

Adding objects to the presentation

  • Select one or more objects in an unlocked patcher. Choose Add to Presentation from the Object menu.

A translucent border will appear around the object(s) you have selected.

  • Click the Presentation Mode button in the patcher toolbar to enter presentation mode. The object you have added will now be visible.
  • You can also remove objects already in the presentation by selecting them and choosing Remove from Presentation from the Object menu. If you are in presentation mode when you do this, the objects will disappear, but they have not been deleted from the patch, just from the presentation.

Repositioning objects in presentation mode

  • Click on the Presentation Mode button on the patcher toolbar in an unlocked patcher to switch to presentation mode and click on an object to select it. You can reposition the selected object(s) by clicking and dragging.

When you return to patching mode, any objects you have repositioned will move back to their functional patching location.


Resizing objects in presentation mode

  • Click the Presentation Mode button in the patcher toolbar in an unlocked patcher. When you switch to presentation mode, any objects you have added to the presentation will be shown. If those objects have been resized or repositioned, they will move and resize themselves. The word (presentation) will appear in the title bar of the patcher window.

In presentation mode, selected objects have resizing handles. If an object can be resized in a horizontal or vertical dimension, the resizing handles will be enabled.

  • Click on a resizing handle and drag it to resize the object. When you switch to patching mode, any objects you have repositioned will move back to their functional patching location.

Configuring a patcher to open in presentation mode

  • With the desired patcher as the active window, choose Patcher Inspector from the View menu.
  • Check the Open in Presentation attribute.

  • Close the patcher inspector and save the patcher.