File Browser Filter Selection

The File Browser sidebar uses a toolbar-like interface that organizes all of the Max files resources in your search path in several ways to allow you easy access to them. You can use the File Browser sidebar to navigate existing files by kind, and to use Collections to create your own virtual file folders of files you use often.

At the top of the tab list are two convenience filters:

  • A Recently Added filter, which shows recently added files
  • A Recently Used filter, which shows Max patches and projects that had recently been accessed

The Kinds Selection

The Kinds Selection in the File Browser sidebar divides and organizes your files by kind:

  • The Audio tab lists all audio files in your search path.
  • The Audioplugin tab lists all VST (.vst) audio plug-ins in your search path. On Macintosh systems, it will also list all Audio Unit (.au) plug-ins.
  • The Code tab lists all Javascript (.js) and Java files (.java) and Java Classes (.class)) in your search path.
  • The Gen tab lists all gen~ (.gendsp) and jit.gen, jit.gl.pix (.genjit) or Gen codebox (.genexpr) resources in your search path.
  • The Genobject tab lists all Gen objects. This includes the Gen objects common to both gen~ )[gen]), jit.gen/jit.gl.pix )[jit]) objects used in both domains )[common]).
  • The Image tab lists all graphic images in various formats (.jpg .png, .tif, .svg, .gif)
  • The Maxforlive tab lists all Max for Live (.amxd) devices
  • The Object tab lists all Max, MSP, and Jitter objects in your search path. This includes not only the standard Max distribution, but also any third-party objects and Packages you have installed
  • The Opengl tab lists all OpenGL files in your search path. This can include AC3D model files (.ac), Biovision BVH (.bvh), BlitzBasic 3D model files (.b3d), Collada model files (.dae), Jitter Material files (.jitmtl), Open GL Shader Language (.glsl), PovRAY raw model files (.raw), Wavefront Object model files (.obj), XML OpenGL Pass Description files (.jxp), and XML Shader Description files (.jxs).
  • The Patcher tab lists all Max patcher (.maxpat) files in your search path.
  • The Project tab lists all Max project (.maxproj) files in your search path.
  • The Snippet tab lists all Max Snippets in your search path.
  • The Text tab lists all text files (.xml, .txt)) in your search path.
  • The Video tab lists all video files (.mov, mp4, etc.)

The Packages Tab

The Packages Tab lists the various groupings of Max externals (both those installed as a part of Max and those third-party objects you may install on your system), Max for Live devices, and Vizzie and BEAP visual and audio processing modules.

The Collections Tab

The Collections Tab in the File Browser sidebar displays all the current Collections - virtual folders filled with files and media you use often. The File Browser is used to create and manage Collections.

The Save Searches Tab

The Saved Searches Tab in the File Browser sidebar provides a way to collect resources which may lie outside of your search path. The tab pre-installs a listing of the audio effects plug-ins currently installed on your system, and also serves as a place to store any file searches you may wish to save.

The Cycling '74 Tab

The Cycling '74 collects and lists all of the resources and materials that are installed with the Max application. These include:

  • Examples - examples of interesting Max, MSP, and Jitter patches, together with code examples (Java and Javascript) and examples of Gen in the audio and visual domains.
  • Tutorials - a listing of all available Max, MSP, and Jitter tutorials.
  • Media - a complete listing of the sounds, movies, and images installed with Max.
  • Audio - MSP example patches.
  • Jitter - Jitter example patches.
  • Javascript - a listing of resources and examples for Javascript programming.
  • Java Resources - a listing of resources and examples for Javas programming.