Max Menu Commands

Max Menus

The File Menu

  • Choosing New Patcher will Create a new patcher window.
  • Choosing New From Template will display a menu of current Template files. When you choose a template, a new patcher using the chosen template file is created.
  • Choosing New From Clipboard will paste the contents of the clipboard into a new patcher window.
  • Choosing New Project will display a file dialog box and let you name a new Project file. When you enter the project name, a new Project will be created and the Project window will appear.
  • Choosing New File Browser will display a new File Browser window.
  • Choosing New Text will Create a new text editor window.
  • Choosing Open... will open an existing patcher, text file, or collective file.
  • Choosing Open as Text... will open the source for a patcher in a text window.
  • Choosing Open Recent Patcher will display a menu of recently opened files and let you choose one.
  • Choosing Open Recent Project will display a menu of recently opened Project files and let you choose one.
  • Choosing Close... will close the current window.
  • Choosing Modify Read Only will Permit a patcher loaded as an abstraction to be edited. If disabled, the current patcher window was not loaded as an abstraction.
  • Choosing Save... will save the current window.
  • Choosing Save As... will save the current window with a new name.
  • Choosing Save As Project... will save the current window as a self-contained file or an application.
  • Choosing Build Collective/Application will save the current window as a self-contained file or an application.
  • Choosing Export Image... will display a dialog box and save the currently selected objects in your patcher window as a visual image in .png format.
  • Choosing List Externals and Subpatcher Files will list of all the patcher files and external objects used by the current patcher in the Max Console.

The Edit Menu

  • Choosing Undo will Undo the previous editing operation.
  • Choosing Redo will Redo the previous editing operation.
  • Choosing Cut will delete the selection and copy it to the clipboard.
  • Choosing Copy will copy the selection to the clipboard.
  • Choosing Copy Compressed will copy the selection to the clipboard in compressed text format.
  • Choosing Paste will paste the contents of the clipboard into the current window.
  • Choosing Delete will delete the selection.
  • Choosing Duplicate will duplicate the selection.
  • Choosing Select All will select everything in the current window.
  • Choosing Paste Picture will create a .png object in the patcher with the image currently on the clipboard.
  • Choosing Paste Replace will replace the currently selected objects with the object on the clipboard.
  • Choosing Encapsulate will transform the currently selected objects into a subpatcher.
  • Choosing De-Encapsulate will transform the currently selected subpatcher into objects in the current patcher.
  • Choosing Find... will show the Find bar in the current window.
  • Choosing Find Next will select the next item that matches the current Find criteria.
  • Choosing Find Previous will select the previous item that matches the current Find criteria.
  • Choosing Resume will restart the scheduler when it has been stopped. This item is only enabled after a stack overflow has occurred.

The View Menu

  • Choosing New View will open another view of a patcher.
  • Choosing Edit will unlock the patcher window. If this is disabled, it means this patcher cannot be edited.
  • Choosing Presentation will Switch between presentation and patching modes. Presentation mode is an easier way to create a user interface for your patcher.
  • Choosing Patcher Inspector will open an inspector window to edit settings that apply to an entire patcher.
  • Choosing Parameters will show the Parameters window.
  • Choosing Zoom in will magnify the topmost patcher window by about 10 percent.
  • Choosing Zoom out will zoom out the topmost patcher window by about 10 percent.
  • Choosing Show at 100% will restore the zoom level of the topmost patcher window to 100%. If this item is disabled, it means the window is currently shown at 100%.
  • Choosing Grid will show or hide the patcher's grid lines when the patcher is unlocked.
  • Choosing Sidebar will show or hide patcher Sidebar which contains the Max Console, Inspector, Reference, and Object Explorer.
  • Choosing Toolbar will show or hide the patcher Toolbar.
  • Choosing Show Connections will Make patch cords visible when the patcher is unlocked.
  • Choosing Hide Foreground will hide the foreground layer of objects in the patcher.
  • Choosing Hide Background will hide the background layer of objects in the patcher.
  • Choosing Show CPU Usage will show the CPU usage for signal processing in the patcher, green (low) to red (high).
  • Choosing Initial Window Location will move the patcher to its initial window location.
  • Choosing Define Fixed Initial Window Location will set the patcher's initial window location.
  • Choosing Clear Initial Window Location will clear the patcher's initial window location.

The Object Menu

  • Choosing Show Fonts will show the font panel to change font settings on the selected object or topmost window.
  • Choosing Name... will edit an object's name for use with pattr objects or patcher scripting.
  • Choosing Inspector will open the inspector window for the selected objects, where you can edit its attributes.
  • Choosing Color... will open the Color Picker used for changing the basic color of the selected objects or patch cords.
  • Choosing Set to Default Values will set object colors to default values.
  • Choosing Hide on Lock will make the selected objects disappear when the patcher is locked.
  • Choosing Show on Lock will make the selected objects visible when the patcher is locked.
  • Choosing Ignore Click will set the selected objects to ignore mouse clicks.
  • Choosing Respond to Click will set the selected objects to respond to mouse clicks.
  • Choosing Add to Presentation will Add the selected objects to the presentation layer, where their size and position can be changed independently.
  • Choosing Remove from Presentation will remove the selected objects from the presentation layer.
  • Choosing Send Message will open a dialog where you can type in a message to send to the selected objects.
  • Choosing Save Prototype will save the selected object's settings so you can create a copy from the the Object action menu or by applying to another object using the Prototype menu.
  • Choosing Prototype will display a menu of prototypes you can apply to the selected object.

The Arrange Menu

  • Choosing Auto Align will align multiple objects to the left/topmost object's top or left edges.
  • Choosing Align will display a menu that lets you choose alignment options - left, center, right, top, middle, or bottom.
  • Choosing Distribute will display a menu that lets you choose horizontal or vertical object distribution.
  • Choosing Scale Spacing... will place a sizing box around the selected objects permitting you to resize them as a group.
  • Choosing Scale... will place a sizing box around the selected objects permitting you to adjust the spacing between them.
  • Choosing Snap to Objects will constrain the movement of objects so they fall onto near object's patcher placement.
  • Choosing Snap to Grid will constrain the movement of objects so they fall onto grid lines.
  • Choosing Route Patch Cords will route the placement of patch cords so that they avoid other objects.
  • Choosing Align Connections will align objects to snap to the inlet/outlet it is connected to.
  • Choosing Remove All Segments will remove all segments from a segmented patch cord.
  • Choosing Bring to Front will move the selected objects ahead of all other objects. If this command is disabled, it means the selected objects are already at the front.
  • Choosing Bring Forward will move the selected objects' front-to-back ordering one step toward the front. If objects are selected and this is disabled, it means the objects are already at the front.
  • Choosing Send to Back will move the selected objects behind all other objects. If this command is disabled, it means the selected objects are already at the back.
  • Choosing Send Backward will move the selected objects' front-to-back order one step toward the back. If objects are selected and this is disabled, it means the objects are already in the back.
  • Choosing Include in Background will move the selected objects from the foreground (default) layer to the background layer.
  • Choosing Remove from Background will move the selected objects from the background layer to the foreground layer.

The Options Menu

  • Choosing Overdrive will enable or disable Overdrive. Overdrive is a scheduler mode that runs timing objects in a high-priority thread, resulting in more accuracy and less interference from other computer tasks.
  • Choosing Auto Fix Width will automatically change the width of text object boxes as you type.
  • Choosing Segmented Patch Cords will enable or disable drawing segmented patch cords.
  • Choosing Assistance will enable or disable object assistance. When enabled, bubbles appear to describe objects' inlets and outlets when you move the cursor over them. When disabled, the descriptions appear in the Status Bar.
  • Choosing Help in Locked Patchers will enable or disable the ability to open an object's help file by option-clicking in a locked patcher window. When disabled, this only happens in an unlocked patcher.
  • Choosing MIDI Setup... will display the MIDI Setup Window where you can assign MIDI input and output ports to channel ranges and letter abbreviations.
  • Choosing Audio Status... will open the Audio Status window where you can change audio driver and performance settings.
  • Choosing OpenGL Status... will open the OpenGL Status window to see properties of the graphics card on your computer.
  • Choosing Object Defaults... will configure the default colors of patcher objects.
  • Choosing File Preferences... will open the File Preferences window, where you can add folders to the Max search path.

The Debug Menu

  • Choosing Enable Debugging will enable/disable debugging. When debugging is enabled, execution of a patch will stop at any active breakpoints.
  • Choosing Debugger will open the Debug window, which shows the current program state when stopped at a Break Watchpoint.
  • Choosing Watchpoints will open the Watchpoints window listing all currently active Break and Monitor Watchpoints.
  • Choosing Probing will enable/disable signal probing. When probing is enabled, Max displays signal or matrix data from the patch cord under the cursor in a locked patcher.
  • Choosing Matrix Probe will show the Matrix Probe window that displays current matrix data transmitted through the patch cord under the cursor in a locked patcher.
  • Choosing Step when program execution is stopped will send the next pending message out an outlet and then suspend execution again.
  • Choosing Pause will stop patch execution and shows where execution is suspended in the Debug Window.
  • Choosing Continue will resume normal execution if program execution is stopped. Execution may stop again if another Break Watchpoint is encountered.
  • Choosing Abort will cancel any further execution when program execution is stopped.
  • Choosing Auto Step will begin executing when program execution is stopped by triggering the next pending message every two seconds, permitting you to watch your patch in slow motion.
  • Choosing Add Watchpoint - Monitor will add a monitor watchpoint to the selected patch cord to record messages passing through it that you can observe in the Watchpoints window.
  • Choosing Add Watchpoint - Break will add a Break Watchpoint (which will suspend execution when debugging is enabled) to the selected patch cord.
  • Choosing Disable Watchpoint will disable the selected watchpoint.
  • Choosing Remove Watchpoint will remove the watchpoint from the selected patch cord.
  • Choosing Remove All Watchpoints will remove all watchpoints from all patchers.
  • Choosing Enable Patch Cord will enable the currently selected patch cord(s).
  • Choosing Disable Patch Cord will disable the currently selected patch cord(s).

The Window Menu

  • Choosing Minimize will reduce the window to the bottom of the screen.
  • Choosing Zoom will toggle between full-screen and a window's normal size.
  • Choosing Send Window to Back will move the window behind all other open windows.
  • Choosing Hide Subwindows Close any open subpatcher windows of the topmost patcher window.
  • Choosing Bring All to Front Move all windows in front of the windows of other applications.
  • Choosing Max Console will show the Max Console.
  • Choosing Magnifier will show the Magnifier window.
  • Choosing Clue Window show the floating Clue window.

The remainder of the Window menu provides a listing of all currently open patcher windows. Choosing a patcher from the menu will bring that patcher's window to Front.

The Extras Menu

The Extras menu contains the names of patches that you can use for reference or utility purposes. You can add your own patches to this folder

  • Choosing Adding Extras... brings up a panel with instructions about how to add patches to this folder.

The remainder of the Extras menu provides a listing of all currently available patchers. Choosing a patcher from the menu will open the patch.